PHP 5.6 supported cms

From Hostcontrol Wiki
Jump to: navigation, search

This page will summarize which major and minor versions of the more popular CMS are compatible with PHP 5.6


  1. Key differences between php5.4 and 5.6

http://php.net/manual/en/migration55.php

http://php.net/manual/en/migration56.php

  1. Joomla!

Earliest version to offer PHP 5.6 support: 3.0

  1. WordPress

Earliest version to offer PHP 5.6 support: 3.9

  1. Drupal

Earliest version to offer PHP 5.6 support: 7 Remark: Version 6 can be patched: http://www.mediacurrent.com/blog/getting-your-drupal-6-site-ready-run-php-56

  1. Magento

Earliest version to offer PHP 5.6 support: 2.0

  1. Prestashop

Earliest version to offer PHP 5.6 support: 1.6

  1. PhpBB

Earliest version to offer PHP 5.6 support: 3.0

  1. Coppermine

Earliest version to offer PHP 5.6 support: 1.5.40? No documentation available

  1. PhpMyFaq

Earliest version to offer PHP 5.6 support: 2.8.2


  1. PhpList

Earliest version to offer PHP 5.6 support: Probably 3.0.7 (documentation unclear)

  1. Lazarus – Offline?

http://carbonize.co.uk/Lazarus/

Earliest version to offer PHP 5.6 support: No documentation available

  1. Gbook

Earliest version to offer PHP 5.6 support: No documentation available

  1. MediaWiki

Earliest version to offer PHP 5.6 support: 1.26